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Error message: Application unauthorized

Error Message:

Error while creating new document. Error message: Application unauthorized. Please authorize before trying to access Google Drive.

Possible Cause:

You may get this error message if you try to generate a document before authorizing your Google Drive.

How to resolve:

  1. Verify that this user is an assigned app user.
  2. Decide if you would like each app user to authorize their own drive or if you would like only one Salesforce user to authorize the app and their Google Drive for ALL app users to generate documents. See this article for more detail on this optional feature.
  3. If you would like each user to authorize the app and their own drive, each user will need to go to the “DocGen Cofiguration” tab and click “Grant access.” Then you will follow the steps to connect the Google Drive account that you would like to use to generate documents. Click here to create a new gmail/google account.