Package Upgrade Issue due to app rebranding from RS Documents to A5 Documents:

If trying to upgrade your package to latest that is available On AppExchange and you see this error message below that refers to “This app can’t be upgraded. There are problems that prevent this package from being installed,” you will need to install a patch version of app with details listed below in this article. The reason for this error is that we went through app rebranding from RS Documents to A5 Documents and we have updated the app with the new naming. This update is not adding any new features, just rebranding. However if you wish to update to the latest version, you will need to follow the steps below to update to a patch version first before updating to the latest version in the future.

Kindly note that we sent email communication out to all primary contacts about this so if you did not receive this email in early 2019, please contact Support to let them know and provide new primary contact information to ensure you receive these important app communications moving forward.

Full Error Message Below:

 

To upgrade your app package to the latest available, please follow these steps:

Step 1: Install Patch Version
Click this link to install the patch version first:
 https://login.salesforce.com/packaging/installPackage.apexp?p0=04t2I000000WnLN.

Step 2: Install the latest version from AppExchange
AppExchange Link:
https://appexchange.salesforce.com/appxListingDetail?listingId=a0N3000000B5O5UEAV.

If you do not install this patch version first, you will receive an error message from AppExchange as detailed in this article.

Change App Display Name:
And if you would like to change the name of the app within your Salesforce org to match package install for A5 Documents, you can do following steps: Setup > Create > Apps > App Label (change to A5 Documents if still says RS Documents).